20Miles for Outlook

Any version capable of running .NET Framework 4.5 is supported. If the .NET Framework is not installed on your computer you can either do this through Windows Update or by clicking here.

20miles for Outlook is supported on Office version 2003 and up.